summaryrefslogtreecommitdiff
path: root/indra/llxml/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
committerJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
commit9b2d9c6e6e43f5600be64c65e42c373a199a3e1d (patch)
treeca16f9a775bcd025671a95a72c12664e142acc47 /indra/llxml/CMakeLists.txt
parent5c2fd1e4fe304e1b6f6d4136f0d1fd3028c3dddd (diff)
Retry. Build system fixes for library-library dependencies, ported from skinning-7. OK by CG.
svn merge -r117623:117624 svn+ssh://svn.lindenlab.com/svn/linden/branches/skinning/skinning-7
Diffstat (limited to 'indra/llxml/CMakeLists.txt')
-rw-r--r--indra/llxml/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/indra/llxml/CMakeLists.txt b/indra/llxml/CMakeLists.txt
index 487c5b9a8a..dc7787beea 100644
--- a/indra/llxml/CMakeLists.txt
+++ b/indra/llxml/CMakeLists.txt
@@ -35,8 +35,10 @@ set_source_files_properties(${llxml_HEADER_FILES}
list(APPEND llxml_SOURCE_FILES ${llxml_HEADER_FILES})
add_library (llxml ${llxml_SOURCE_FILES})
-target_link_libraries(
- llxml
+# Libraries on which this library depends, needed for Linux builds
+# Sort by high-level to low-level
+target_link_libraries( llxml
+ llmath
${BOOST_SIGNALS_LIBRARY}
${EXPAT_LIBRARIES}
)