summaryrefslogtreecommitdiff
path: root/indra/llxml/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-10-08 20:08:36 +0800
committerErik Kundiman <erik@megapahit.org>2023-10-08 20:08:36 +0800
commit10fff388a6a1594d73f33cac9b867f1fab516d5b (patch)
treeb1b3b272c33056b11f2d84eab65406a437c05166 /indra/llxml/CMakeLists.txt
parent78fdc1e2c8da0479160d3cf76f01dd234b74ea31 (diff)
Prepare SDL2 for file read operations
Necessary on some platforms.
Diffstat (limited to 'indra/llxml/CMakeLists.txt')
-rw-r--r--indra/llxml/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/llxml/CMakeLists.txt b/indra/llxml/CMakeLists.txt
index 748e3e8b61..03ac4bc9f2 100644
--- a/indra/llxml/CMakeLists.txt
+++ b/indra/llxml/CMakeLists.txt
@@ -4,6 +4,7 @@ project(llxml)
include(00-Common)
include(LLCommon)
+include(LLWindow)
set(llxml_SOURCE_FILES
llcontrol.cpp
@@ -31,6 +32,7 @@ target_link_libraries( llxml
llmath
llcommon
ll::expat
+ ll::SDL
)
target_include_directories( llxml INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})