summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Lihatskiy <alihatskiy@productengine.com>2022-10-20 22:34:11 +0300
committerAndrey Lihatskiy <alihatskiy@productengine.com>2022-10-20 22:34:11 +0300
commite0ace0c722ee06f961bad6dd15abf9ba68ea540e (patch)
treecebb7ccd24bf355a576751d71d9f8736bd72b53b /indra/llwindow/CMakeLists.txt
parent589a167147fd4a316f4cf588bbb2aaa103c9d3bb (diff)
parente45b6159666b3aa271eaaa366fb4bcade2c2a28b (diff)
Merge branch 'master' into DRTVWR-570-maint-Q
# Conflicts: # indra/newview/llnetmap.cpp # indra/newview/llnetmap.h
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index 70eb99c86c..55befaef51 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -197,4 +197,10 @@ if (SDL_FOUND)
endif (SDL_FOUND)
target_link_libraries (llwindow ${llwindow_LINK_LIBRARIES})
+
+if (DARWIN)
+ include(CMakeFindFrameworks)
+ find_library(CARBON_LIBRARY Carbon)
+ target_link_libraries(llwindow ${CARBON_LIBRARY})
+endif (DARWIN)