summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-12 16:17:02 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-19 12:42:50 +0800
commitb844e48297b6650003aa1f24bef618f7b652466c (patch)
tree6dd15c6a0964e2a73773e0d70a196c67e9358ce7 /indra/llwindow/CMakeLists.txt
parent008a46e3080e811fe5e34607c0c4cceb77d829d5 (diff)
FreeBSD has SDL keyboard & window files built too
and any Linux SDL code should be applied to FreeBSD too.
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index ca08e38f77..c2989e84c9 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -61,7 +61,7 @@ set(llwindow_LINK_LIBRARIES
)
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
-if (LINUX)
+if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
list(APPEND viewer_SOURCE_FILES
llkeyboardsdl.cpp
llwindowsdl.cpp
@@ -84,7 +84,7 @@ if (LINUX)
)
endif (BUILD_HEADLESS)
-endif (LINUX)
+endif (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
if (DARWIN)
list(APPEND llwindow_SOURCE_FILES