summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2010-12-24 07:41:41 -0500
committerOz Linden <oz@lindenlab.com>2010-12-24 07:41:41 -0500
commit14d830ca43a7114140ebeb16a76829db4d21a95b (patch)
tree169ab24a903d59c762259810de684f1dcb8c4186 /indra/llwindow/CMakeLists.txt
parent551bfb88fce8a9cd6faac440e3d89d79213550ed (diff)
parent5a4bb72b8d37ca51deb84e1490fdefe2908d2d59 (diff)
merge improved fix for STORM_785
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index bf3233f386..4d2677fd91 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -59,12 +59,13 @@ set(viewer_HEADER_FILES
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
-if (NOT LINUX OR VIEWER)
+if (LINUX AND VIEWER)
set(llwindow_LINK_LIBRARIES
${UI_LIBRARIES} # for GTK
${SDL_LIBRARY}
+ fontconfig # For FCInit and other FC* functions.
)
-endif (NOT LINUX OR VIEWER)
+endif (LINUX AND VIEWER)
if (DARWIN)
list(APPEND llwindow_SOURCE_FILES