summaryrefslogtreecommitdiff
path: root/indra/llvfs/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
commit9db949eec327df4173fde3de934a87bedb0db13c (patch)
treeaeffa0f0e68b1d2ceb74d460cbbd22652c9cd159 /indra/llvfs/CMakeLists.txt
parent419e13d0acaabf5e1e02e9b64a07648bce822b2f (diff)
svn merge -r88066:88786 svn+ssh://svn.lindenlab.com/svn/linden/branches/cmake-9-merge
dataserver-is-deprecated for-fucks-sake-whats-with-these-commit-markers
Diffstat (limited to 'indra/llvfs/CMakeLists.txt')
-rw-r--r--indra/llvfs/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/indra/llvfs/CMakeLists.txt b/indra/llvfs/CMakeLists.txt
new file mode 100644
index 0000000000..9f136f7772
--- /dev/null
+++ b/indra/llvfs/CMakeLists.txt
@@ -0,0 +1,58 @@
+# -*- cmake -*-
+
+project(llvfs)
+
+include(00-Common)
+include(LLCommon)
+include(UnixInstall)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ )
+
+set(llvfs_SOURCE_FILES
+ lldir.cpp
+ lllfsthread.cpp
+ llvfile.cpp
+ llvfs.cpp
+ llvfsthread.cpp
+ )
+
+set(llvfs_HEADER_FILES
+ CMakeLists.txt
+
+ lldir.h
+ lllfsthread.h
+ llvfile.h
+ llvfs.h
+ llvfsthread.h
+ )
+
+if (DARWIN)
+ LIST(APPEND llvfs_SOURCE_FILES lldir_mac.cpp)
+ LIST(APPEND llvfs_HEADER_FILES lldir_mac.h)
+endif (DARWIN)
+
+if (LINUX)
+ LIST(APPEND llvfs_SOURCE_FILES lldir_linux.cpp)
+ LIST(APPEND llvfs_HEADER_FILES lldir_linux.h)
+
+ if (VIEWER AND INSTALL)
+ set_source_files_properties(lldir_linux.cpp
+ PROPERTIES COMPILE_FLAGS
+ "-DAPP_RO_DATA_DIR=\\\"${APP_SHARE_DIR}\\\""
+ )
+ endif (VIEWER AND INSTALL)
+endif (LINUX)
+
+if (WINDOWS)
+ LIST(APPEND llvfs_SOURCE_FILES lldir_win32.cpp)
+ LIST(APPEND llvfs_HEADER_FILES lldir_win32.h)
+endif (WINDOWS)
+
+set_source_files_properties(${llvfs_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llvfs_SOURCE_FILES ${llvfs_HEADER_FILES})
+
+add_library (llvfs ${llvfs_SOURCE_FILES})