summaryrefslogtreecommitdiff
path: root/indra/llvfs/CMakeLists.txt
diff options
context:
space:
mode:
authorSeth ProductEngine <slitovchuk@productengine.com>2011-05-11 18:12:48 +0300
committerSeth ProductEngine <slitovchuk@productengine.com>2011-05-11 18:12:48 +0300
commit662bc0803cc9306062a0106467fd8b83290b4bcf (patch)
treecfbb309391ad8a52b0cd20b52dcc9bb4c85ddffb /indra/llvfs/CMakeLists.txt
parentd86eb3dd42d39e6b7647b6680100aeafe2173d36 (diff)
STORM-477 Restored the backed out changeset: c9cc202293b7
Diffstat (limited to 'indra/llvfs/CMakeLists.txt')
-rw-r--r--indra/llvfs/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llvfs/CMakeLists.txt b/indra/llvfs/CMakeLists.txt
index 722f4e2bfd..a3782d824b 100644
--- a/indra/llvfs/CMakeLists.txt
+++ b/indra/llvfs/CMakeLists.txt
@@ -12,6 +12,7 @@ include_directories(
set(llvfs_SOURCE_FILES
lldir.cpp
+ lldiriterator.cpp
lllfsthread.cpp
llpidlock.cpp
llvfile.cpp
@@ -24,6 +25,7 @@ set(llvfs_HEADER_FILES
lldir.h
lldirguard.h
+ lldiriterator.h
lllfsthread.h
llpidlock.h
llvfile.h
@@ -60,6 +62,11 @@ list(APPEND llvfs_SOURCE_FILES ${llvfs_HEADER_FILES})
add_library (llvfs ${llvfs_SOURCE_FILES})
+target_link_libraries(llvfs
+ ${BOOST_FILESYSTEM_LIBRARY}
+ ${BOOST_SYSTEM_LIBRARY}
+ )
+
if (DARWIN)
include(CMakeFindFrameworks)
find_library(CARBON_LIBRARY Carbon)