summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cook <james@lindenlab.com>2009-10-03 23:40:28 +0000
committerJames Cook <james@lindenlab.com>2009-10-03 23:40:28 +0000
commitada0f4fa221f2c7070fb02a2b7ff903bdde11c45 (patch)
tree0ede83511c304110138c01d16da2fff55162ef31 /indra/llui/CMakeLists.txt
parentb1a280841e1823a19658923a8eefeb67d1d70735 (diff)
Merge inspectors UI project, gooey-4, into viewer-2 trunk. Added new tooltips to 3D avatars, 2D avatar names, and 3D objects. Refactors tooltips and text boxes, line editors, and text editors. Breaks LLExpandableTextBox, but a fix is coming.
Resolved conflicts in lltexteditor.cpp, llchatitemscontainerctrl.cpp, llchatmsgbox.cpp, llfloaterbuycurrency.cpp, llnearbychat.cpp, floater_buy_currency.xml, and ru/strings.xml Merging revisions 134925-135157 of svn+ssh://svn.lindenlab.com/svn/linden/branches/gooey/gooey-4 into C:\source\viewer-2.0.0-3, respecting ancestry
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 0a284f0088..d9169f57f9 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -51,6 +51,7 @@ set(llui_SOURCE_FILES
lllayoutstack.cpp
lllineeditor.cpp
lllocalcliprect.cpp
+ llmenubutton.cpp
llmenugl.cpp
llmodaldialog.cpp
llmultifloater.cpp
@@ -87,6 +88,7 @@ set(llui_SOURCE_FILES
lltextparser.cpp
lltransientfloatermgr.cpp
lltransutil.cpp
+ lltoggleablemenu.cpp
lltooltip.cpp
llui.cpp
lluicolortable.cpp
@@ -137,6 +139,7 @@ set(llui_HEADER_FILES
lllazyvalue.h
lllineeditor.h
lllocalcliprect.h
+ llmenubutton.h
llmenugl.h
llmodaldialog.h
llmultifloater.h
@@ -171,6 +174,7 @@ set(llui_HEADER_FILES
lltextbox.h
lltexteditor.h
lltextparser.h
+ lltoggleablemenu.h
lltooltip.h
lltransientfloatermgr.h
lltransutil.h