summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
committerJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
commit9b2d9c6e6e43f5600be64c65e42c373a199a3e1d (patch)
treeca16f9a775bcd025671a95a72c12664e142acc47 /indra/llui/CMakeLists.txt
parent5c2fd1e4fe304e1b6f6d4136f0d1fd3028c3dddd (diff)
Retry. Build system fixes for library-library dependencies, ported from skinning-7. OK by CG.
svn merge -r117623:117624 svn+ssh://svn.lindenlab.com/svn/linden/branches/skinning/skinning-7
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 32118e8a69..5de8dc76af 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -141,3 +141,14 @@ set_source_files_properties(${llui_HEADER_FILES}
list(APPEND llui_SOURCE_FILES ${llui_HEADER_FILES})
add_library (llui ${llui_SOURCE_FILES})
+# Libraries on which this library depends, needed for Linux builds
+# Sort by high-level to low-level
+target_link_libraries(llui
+ llrender
+ llwindow
+ llimage
+ llvfs # ugh, just for LLDir
+ llxml
+ llcommon # must be after llimage, llwindow, llrender
+ llmath
+ )