summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorLeslie Linden <none@none>2011-06-08 13:14:15 -0700
committerLeslie Linden <none@none>2011-06-08 13:14:15 -0700
commit888b39c283e53fd128778e70e231bcb6053de4b8 (patch)
tree995b188468da71dde79924d9af174e9b7fca494d /indra/llui/CMakeLists.txt
parentd8e84f85c9377a9bfd628d61ee1a661c31f3db84 (diff)
EXP-865 PROGRESS -- Modify LLBadge to allow it to hang off of non-buttons
Moved LLBadge use from LLButton into a separate LLBadgeOwner class. LLButton now derives from LLBadgeOwner which handles the bulk of the badge management.
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index fb585e062c..e9283788bd 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -29,6 +29,7 @@ set(llui_SOURCE_FILES
llaccordionctrl.cpp
llaccordionctrltab.cpp
llbadge.cpp
+ llbadgeowner.cpp
llbutton.cpp
llcheckboxctrl.cpp
llclipboard.cpp
@@ -121,6 +122,7 @@ set(llui_HEADER_FILES
llaccordionctrl.h
llaccordionctrltab.h
llbadge.h
+ llbadgeowner.h
llbutton.h
llcallbackmap.h
llcheckboxctrl.h