summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-11-04 10:49:38 +0800
committerErik Kundiman <erik@megapahit.org>2024-11-04 10:49:38 +0800
commit6fa1d6ae41f804cf262da00949ae7978dc3020bc (patch)
treec728ec6212f64515d2e8d311db4e6d61c77b89aa /indra/llui/CMakeLists.txt
parent7d3bfdc65736f9939230b058d98407e55ba6f2a5 (diff)
Set so restrict & use-after-free aren't GCC errors
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 76bb71953c..e616d30998 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -273,6 +273,16 @@ target_link_libraries(llui
ll::SDL2
)
+if (CMAKE_CXX_COMPILER_ID MATCHES GNU)
+ set_source_files_properties(
+ llcheckboxctrl.cpp
+ llresmgr.cpp
+ PROPERTIES COMPILE_FLAGS -Wno-restrict)
+ set_source_files_properties(
+ llflatlistview.cpp
+ PROPERTIES COMPILE_FLAGS -Wno-use-after-free)
+endif (CMAKE_CXX_COMPILER_ID MATCHES GNU)
+
include(LibraryInstall)
# Add tests