summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authormaksymsproductengine <maksymsproductengine@lindenlab.com>2014-09-22 20:01:55 +0300
committermaksymsproductengine <maksymsproductengine@lindenlab.com>2014-09-22 20:01:55 +0300
commit61e05f912557e3086cd80a10075aeaa6586519be (patch)
tree273d774f45d2522041c752015dc4247890dfc7e3 /indra/llui/CMakeLists.txt
parent9c4a8951fffb2a649647178f396f01cf68f114fc (diff)
MAINT-4170 Eliminate homoglyphs in URL hostnames: used 3p-uriparser;
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rwxr-xr-xindra/llui/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 52738aeb6f..24fdc2268d 100755
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -12,6 +12,7 @@ include(LLRender)
include(LLWindow)
include(LLVFS)
include(LLXML)
+include(URIPARSER)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
@@ -28,6 +29,7 @@ include_directories(
include_directories(SYSTEM
${LLCOMMON_SYSTEM_INCLUDE_DIRS}
${LLXML_SYSTEM_INCLUDE_DIRS}
+ ${URIPARSER_INCLUDE_DIRS}
)
set(llui_SOURCE_FILES
@@ -278,6 +280,7 @@ target_link_libraries(llui
${LLXML_LIBRARIES}
${LLMATH_LIBRARIES}
${HUNSPELL_LIBRARY}
+ ${URIPARSER_LIBRARIES}
${LLCOMMON_LIBRARIES} # must be after llimage, llwindow, llrender
)