summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-13 19:21:55 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-13 19:21:55 +0200
commit241919e7f7986c11586a49bff53cf19c2c0e0ea6 (patch)
treedfd7f4fa971fd77c89eaaa140ba1e53b910b24aa /indra/llui/CMakeLists.txt
parent2c9ede0ccc3b6a27ca418fcb6e7a91eb87b261e9 (diff)
Rework cmake, the original plan was to maybe be able to use conan targets with the same name (that's why 3ps had names like apr::apr),
but it's safer and saner to put the LL 3ps under the ll:: prefix. This also allows means it is possible to get rid of that bad "if( TRAGET ...) return() endif()" pattern and rather use include_guard().
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 04103b1a94..9035095d5f 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -265,14 +265,14 @@ target_link_libraries(llui
llfilesystem
llxml
llmath
- hunspell::hunspell
+ ll::hunspell
llcommon
)
# Add tests
if(LL_TESTS)
include(LLAddBuildTest)
- set(test_libs llmessage llcorehttp llxml llrender llcommon hunspell::hunspell ${WINDOWS_LIBRARIES})
+ set(test_libs llmessage llcorehttp llxml llrender llcommon ll::hunspell ${WINDOWS_LIBRARIES})
SET(llui_TEST_SOURCE_FILES
llurlmatch.cpp
@@ -282,7 +282,7 @@ if(LL_TESTS)
# INTEGRATION TESTS
if(NOT LINUX)
- set(test_libs llui llmessage llcorehttp llxml llrender llcommon hunspell::hunspell ${WINDOWS_LIBRARIES})
+ set(test_libs llui llmessage llcorehttp llxml llrender llcommon ll::hunspell ${WINDOWS_LIBRARIES})
LL_ADD_INTEGRATION_TEST(llurlentry llurlentry.cpp "${test_libs}")
endif(NOT LINUX)
endif(LL_TESTS)