summaryrefslogtreecommitdiff
path: root/indra/llrender/CMakeLists.txt
diff options
context:
space:
mode:
authorCallum Prentice <callum@gmail.com>2020-09-17 09:45:06 -0700
committerCallum Prentice <callum@gmail.com>2020-09-17 09:45:06 -0700
commitd9448c6f52218146113d1d5c5ca4c4d5f01dc5cf (patch)
treea264e71da59ef1a0ecf78e0a2cba0bb3bdc3ff1c /indra/llrender/CMakeLists.txt
parent20b50f99c89271518ae37ade0ef0866167070c80 (diff)
The folder where the disk cache lives was originally renamed from llvfs to llcache but @henri's suggestion that that doesn't reflect the other files in the same place and it should be llfilesystem is a good one so I changed it over
Diffstat (limited to 'indra/llrender/CMakeLists.txt')
-rw-r--r--indra/llrender/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/indra/llrender/CMakeLists.txt b/indra/llrender/CMakeLists.txt
index 524e2a1729..baab09a104 100644
--- a/indra/llrender/CMakeLists.txt
+++ b/indra/llrender/CMakeLists.txt
@@ -11,7 +11,7 @@ include(LLMath)
include(LLRender)
include(LLWindow)
include(LLXML)
-include(LLCache)
+include(LLFileSystem)
include_directories(
${FREETYPE_INCLUDE_DIRS}
@@ -19,10 +19,9 @@ include_directories(
${LLIMAGE_INCLUDE_DIRS}
${LLMATH_INCLUDE_DIRS}
${LLRENDER_INCLUDE_DIRS}
- ${LLCACHE_INCLUDE_DIRS}
+ ${LLFILESYSTEM_INCLUDE_DIRS}
${LLWINDOW_INCLUDE_DIRS}
${LLXML_INCLUDE_DIRS}
- ${LLCACHE_INCLUDE_DIRS}
)
include_directories(SYSTEM
${LLCOMMON_SYSTEM_INCLUDE_DIRS}
@@ -103,9 +102,8 @@ if (BUILD_HEADLESS)
${LLIMAGE_LIBRARIES}
${LLMATH_LIBRARIES}
${LLRENDER_HEADLESS_LIBRARIES}
- ${LLCACHE_LIBRARIES}
${LLXML_LIBRARIES}
- ${LLCACHE_LIBRARIES}
+ ${LLFILESYSTEM_LIBRARIES}
${LLWINDOW_HEADLESS_LIBRARIES}
${OPENGL_HEADLESS_LIBRARIES})
@@ -125,7 +123,7 @@ target_link_libraries(llrender
${LLCOMMON_LIBRARIES}
${LLIMAGE_LIBRARIES}
${LLMATH_LIBRARIES}
- ${LLCACHE_LIBRARIES}
+ ${LLFILESYSTEM_LIBRARIES}
${LLXML_LIBRARIES}
${LLWINDOW_LIBRARIES}
${FREETYPE_LIBRARIES}