summaryrefslogtreecommitdiff
path: root/indra/llplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMonroe Williams <monroe@lindenlab.com>2009-08-27 19:00:18 +0000
committerMonroe Williams <monroe@lindenlab.com>2009-08-27 19:00:18 +0000
commit745845f79987e4b4ab7f5728746a0eda8898930f (patch)
treef10efd4a638a6a7eda92a960cdb97e5256ff736a /indra/llplugin/CMakeLists.txt
parent71344b233d5ae3d5262a492b636af04544952611 (diff)
svn merge -r 129841:129910 svn+ssh://svn.lindenlab.com/svn/linden/branches/moss/pluginapi_05-merge@129910
svn merge -r 129913:131718 svn+ssh://svn.lindenlab.com/svn/linden/branches/pluginapi/pluginapi_05 Some branch shenannigans in the pluginapi_05 branch caused this to become a two-part merge.
Diffstat (limited to 'indra/llplugin/CMakeLists.txt')
-rw-r--r--indra/llplugin/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/indra/llplugin/CMakeLists.txt b/indra/llplugin/CMakeLists.txt
new file mode 100644
index 0000000000..6706775d4f
--- /dev/null
+++ b/indra/llplugin/CMakeLists.txt
@@ -0,0 +1,55 @@
+# -*- cmake -*-
+
+project(llplugin)
+
+include(00-Common)
+include(LLCommon)
+include(LLImage)
+include(LLMath)
+include(LLMessage)
+include(LLRender)
+include(LLXML)
+include(LLWindow)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLIMAGE_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LLMESSAGE_INCLUDE_DIRS}
+ ${LLRENDER_INCLUDE_DIRS}
+ ${LLXML_INCLUDE_DIRS}
+ ${LLWINDOW_INCLUDE_DIRS}
+ )
+
+set(llplugin_SOURCE_FILES
+ llpluginclassmedia.cpp
+ llplugininstance.cpp
+ llpluginmessage.cpp
+ llpluginmessagepipe.cpp
+ llpluginprocesschild.cpp
+ llpluginprocessparent.cpp
+ llpluginsharedmemory.cpp
+ )
+
+set(llplugin_HEADER_FILES
+ CMakeLists.txt
+
+ llpluginclassmedia.h
+ llpluginclassmediaowner.h
+ llplugininstance.h
+ llpluginmessage.h
+ llpluginmessageclasses.h
+ llpluginmessagepipe.h
+ llpluginprocesschild.h
+ llpluginprocessparent.h
+ llpluginsharedmemory.h
+ )
+
+set_source_files_properties(${llplugin_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES})
+
+add_library (llplugin ${llplugin_SOURCE_FILES})
+
+add_subdirectory(slplugin)