summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-11 16:29:26 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-19 10:48:02 +0800
commita763de1cfa21a184e0c941c5a3618125af366939 (patch)
treeaffd549a66a61b8e913abbbd05ba15531624726c /indra/llmessage/CMakeLists.txt
parentc718c518f86e3bd78bd71bbd07fbc626373bbe96 (diff)
No GoogleMock, AddBuildTest & Tut when no LL_TESTS
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index 4786956e85..2fef3cf15b 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -3,13 +3,19 @@
project(llmessage)
include(00-Common)
+if (LL_TESTS)
include(GoogleMock)
include(LLAddBuildTest)
+endif ()
include(LLCommon)
include(LLCoreHttp)
+if (LL_TESTS)
include(LLAddBuildTest)
+endif ()
include(Python)
+if (LL_TESTS)
include(Tut)
+endif ()
include(Python)
include(JsonCpp)