summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorRider Linden <rider@lindenlab.com>2015-05-20 17:37:27 -0700
committerRider Linden <rider@lindenlab.com>2015-05-20 17:37:27 -0700
commitc437a9c4ec865c38366c8057010d24311888ecb1 (patch)
treed505cbcd4d1455b309689d170b24485a3ff94087 /indra/llmessage/CMakeLists.txt
parenta4741cecb2112f418c1d98ca63a261e707a856c3 (diff)
Webprofile converted to coroutine.
Added JSON->LLSD converter Added corohandler for JSON data
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rwxr-xr-xindra/llmessage/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index f6ca6a3634..51b8ed6c62 100755
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -14,6 +14,7 @@ include(LLAddBuildTest)
include(Python)
include(Tut)
include(Python)
+include(JsonCpp)
include_directories (${CMAKE_CURRENT_SOURCE_DIR})
@@ -23,6 +24,7 @@ include_directories(
${LLMATH_INCLUDE_DIRS}
${LLMESSAGE_INCLUDE_DIRS}
${LLVFS_INCLUDE_DIRS}
+ ${JSONCPP_INCLUDE_DIR}
)
set(llmessage_SOURCE_FILES
@@ -229,6 +231,7 @@ target_link_libraries(
${LLVFS_LIBRARIES}
${LLMATH_LIBRARIES}
${CARES_LIBRARIES}
+ ${JSONCPP_LIBRARIES}
${OPENSSL_LIBRARIES}
${CRYPTO_LIBRARIES}
${XMLRPCEPI_LIBRARIES}
@@ -254,6 +257,7 @@ if (LL_TESTS)
${LLCOMMON_LIBRARIES}
${LLMESSAGE_LIBRARIES}
${LLCOREHTTP_LIBRARIES}
+ ${JSONCPP_LIBRARIES}
${BOOST_CONTEXT_LIBRARY}
${BOOST_COROUTINE_LIBRARY}
${GOOGLEMOCK_LIBRARIES}