summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 20:51:40 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 20:51:40 +0800
commitd74367b40d3a2680bbc371b72e294419093e1d83 (patch)
treec047043f633c4d3e6e02cd03748354a43f92d5e2 /indra/llmessage/CMakeLists.txt
parent061eb674576157b72be23c9bc8c9d3ab905d280f (diff)
stringop truncation warnings aren't errors on GCC
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index 2fef3cf15b..92a5f783e0 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -203,6 +203,13 @@ target_link_libraries(
)
target_include_directories( llmessage INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
+if (NOT (USE_AUTOBUILD_3P OR USE_CONAN))
+ if (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ set_source_files_properties(llnamevalue.cpp PROPERTIES
+ COMPILE_FLAGS -Wno-stringop-truncation)
+ endif()
+endif ()
+
# tests
if (LL_TESTS)
SET(llmessage_TEST_SOURCE_FILES