summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Knop <prospero@lindenlab.com>2009-02-25 21:02:17 +0000
committerRobert Knop <prospero@lindenlab.com>2009-02-25 21:02:17 +0000
commitc88b470a8a2cdae8e69e5570b46d4b21c43368bc (patch)
tree551d764767aa1d9c095a99b586f5bb38ae3f1e57 /indra/llmessage/CMakeLists.txt
parent997d24b83221aa63ef8141a9ab94434d2ba2ddc6 (diff)
svn merge -r108815:112761 svn+ssh://svn.lindenlab.com/svn/linden/branches/server/server-1.26
The biggest things in this are Scalable Space Servers and Maint-Server-6 QAR-1209 : SSS QAR-1295 : maint-server-6 Conflicts resolved by prospero: C scripts/farm_distribute C scripts/automated_build_scripts/build-linux.sh : resolved by prospero, mostly kept the merge-right version in the conflict, but there was one block of repeated code from earlier that I removed. C scripts/automated_build_scripts/build-mac.sh : kept merge-right C indra/llcommon/llversionserver.h : svn revert C indra/newsim/llsimparcel.h : kept *both*... working had "setArea", merge-right had exportStream and importStream C indra/newsim/llsimparcel.cpp : see llsimparcel.h C indra/newsim/lltask.h : working had LLTask derived also from LLScriptResourceConsumer, merge-right had LLTask dervied also from LLAgentPosition. To resolve conflict, derive from both. C indra/newsim/lllslmanager.h : kept merge-right (had an added comment) C indra/llmessage/llhttpnode.h : kept working (added the definition of method LLHTTPNode::extendedResult) C indra/lscript/lscript_execute_mono/llscriptexecutemono.cpp C indra/lscript/lscript_execute_mono/llscriptexecutemono.h : These two were resolved by si, in consultation with daveh I also had to add the following stubs to indra/newsim/tests/llgodkickutils_test.cpp in order to get it to compile: // LLScriptResourceConsumer interface methods in LLTask LLScriptResource::LLScriptResource() { } LLScriptResourcePool::LLScriptResourcePool() { } LLScriptResourcePool LLScriptResourcePool::null; LLScriptResourceConsumer::LLScriptResourceConsumer() { } LLScriptResourcePool& LLScriptResourceConsumer::getScriptResourcePool() { return LLScriptResourcePool::null; } const LLScriptResourcePool& LLScriptResourceConsumer::getScriptResourcePool() const { return LLScriptResourcePool::null; } bool LLScriptResourceConsumer::switchScriptResourcePools(LLScriptResourcePool& new_pool) { return false; } bool LLScriptResourceConsumer::canUseScriptResourcePool(const LLScriptResourcePool& resource_pool) { return false; } bool LLScriptResourceConsumer::isInPool(const LLScriptResourcePool& resource_pool) { return false; } void LLScriptResourceConsumer::setScriptResourcePool(LLScriptResourcePool& pool) { } S32 LLTask::getUsedPublicURLs() const { return 0; } void LLTask::setScriptResourcePool(LLScriptResourcePool& pool) { }
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt25
1 files changed, 23 insertions, 2 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index fd22de9399..4fb0187412 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -7,6 +7,7 @@ include(LLCommon)
include(LLMath)
include(LLMessage)
include(LLVFS)
+include(LLAddBuildTest)
include_directories (${CMAKE_CURRENT_SOURCE_DIR})
@@ -34,6 +35,7 @@ set(llmessage_SOURCE_FILES
llhost.cpp
llhttpassetstorage.cpp
llhttpclient.cpp
+ llhttpclientadapter.cpp
llhttpnode.cpp
llhttpsender.cpp
llinstantmessage.cpp
@@ -57,6 +59,7 @@ set(llmessage_SOURCE_FILES
llpacketring.cpp
llpartdata.cpp
llpumpio.cpp
+ llregionpresenceverifier.cpp
llsdappservices.cpp
llsdhttpserver.cpp
llsdmessagebuilder.cpp
@@ -65,7 +68,9 @@ set(llmessage_SOURCE_FILES
llsdrpcserver.cpp
llservicebuilder.cpp
llservice.cpp
+ llstoredmessage.cpp
lltemplatemessagebuilder.cpp
+ lltemplatemessagedispatcher.cpp
lltemplatemessagereader.cpp
llthrottle.cpp
lltransfermanager.cpp
@@ -73,6 +78,7 @@ set(llmessage_SOURCE_FILES
lltransfersourcefile.cpp
lltransfertargetfile.cpp
lltransfertargetvfile.cpp
+ lltrustedmessageservice.cpp
llurlrequest.cpp
lluseroperation.cpp
llxfer.cpp
@@ -85,7 +91,6 @@ set(llmessage_SOURCE_FILES
message_prehash.cpp
message_string_table.cpp
net.cpp
- network.cpp
partsyspacket.cpp
patch_code.cpp
patch_dct.cpp
@@ -115,7 +120,10 @@ set(llmessage_HEADER_FILES
llhost.h
llhttpassetstorage.h
llhttpclient.h
+ llhttpclientinterface.h
+ llhttpclientadapter.h
llhttpnode.h
+ llhttpnodeadapter.h
llhttpsender.h
llinstantmessage.h
llinvite.h
@@ -144,6 +152,7 @@ set(llmessage_HEADER_FILES
llqueryflags.h
llregionflags.h
llregionhandle.h
+ llregionpresenceverifier.h
llsdappservices.h
llsdhttpserver.h
llsdmessagebuilder.h
@@ -152,9 +161,11 @@ set(llmessage_HEADER_FILES
llsdrpcserver.h
llservice.h
llservicebuilder.h
+ llstoredmessage.h
lltaskname.h
llteleportflags.h
lltemplatemessagebuilder.h
+ lltemplatemessagedispatcher.h
lltemplatemessagereader.h
llthrottle.h
lltransfermanager.h
@@ -162,6 +173,7 @@ set(llmessage_HEADER_FILES
lltransfersourcefile.h
lltransfertargetfile.h
lltransfertargetvfile.h
+ lltrustedmessageservice.h
llurlrequest.h
lluseroperation.h
llvehicleparams.h
@@ -176,7 +188,6 @@ set(llmessage_HEADER_FILES
message.h
message_prehash.h
net.h
- network.h
partsyspacket.h
patch_code.h
patch_dct.h
@@ -197,3 +208,13 @@ target_link_libraries(
${CRYPTO_LIBRARIES}
${XMLRPCEPI_LIBRARIES}
)
+
+IF (NOT LINUX AND VIEWER)
+ # When building the viewer the tests links against the shared objects.
+ # These can not be found when we try to run the tests, so we had to disable them, for the viewer build.
+ # TODO: Can someone with viewer knowledge figure out how to make these find the correct so.
+ #ADD_BUILD_TEST(llhttpclientadapter llmessage)
+ ADD_BUILD_TEST(lltrustedmessageservice llmessage)
+ ADD_BUILD_TEST(lltemplatemessagedispatcher llmessage)
+ENDIF (NOT LINUX AND VIEWER)
+