summaryrefslogtreecommitdiff
path: root/indra/llmeshoptimizer/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Kleshchev <andreykproductengine@lindenlab.com>2021-07-06 21:26:15 +0300
committerAndrey Kleshchev <andreykproductengine@lindenlab.com>2021-07-07 00:42:31 +0300
commit97c954dd84d50ec7b739d2dd3adb7365589f3034 (patch)
treedd6383f3f7c1d7a89118a3968a28c8a737e43b7a /indra/llmeshoptimizer/CMakeLists.txt
parent467d8339c970c253dada2cf0e1eed45be66593ac (diff)
SL-15522 Initial addition of meshoptimizer
Diffstat (limited to 'indra/llmeshoptimizer/CMakeLists.txt')
-rw-r--r--indra/llmeshoptimizer/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/indra/llmeshoptimizer/CMakeLists.txt b/indra/llmeshoptimizer/CMakeLists.txt
new file mode 100644
index 0000000000..1eea19de66
--- /dev/null
+++ b/indra/llmeshoptimizer/CMakeLists.txt
@@ -0,0 +1,41 @@
+# -*- cmake -*-
+
+project(llmeshoptimizer)
+
+include(MESHOPTIMIZER)
+
+include(00-Common)
+include(LLCommon)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMESHOPTIMIZER_INCLUDE_DIR}
+ ${MESHOPTIMIZER_INCLUDE_DIRS}
+ ${LIBS_PREBUILT_DIR}/include #access to boost headers, needed for LLError
+ )
+
+set(llmeshoptimizer_SOURCE_FILES
+ llmeshoptimizer.cpp
+ )
+
+set(llmeshoptimizer_HEADER_FILES
+ CMakeLists.txt
+
+ llmeshoptimizer.h
+ )
+
+set_source_files_properties(${llmeshoptimizer_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llmeshoptimizer_SOURCE_FILES ${llmeshoptimizer_HEADER_FILES})
+
+#if (USE_MESHOPT)
+ add_library (llmeshoptimizer ${llmeshoptimizer_SOURCE_FILES})
+
+ target_link_libraries(llmeshoptimizer
+ ${LLCOMMON_LIBRARIES}
+ ${MESHOPTIMIZER_LIBRARY})
+
+ # Add tests
+
+#endif (USE_MESHOPT)