summaryrefslogtreecommitdiff
path: root/indra/llmath/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 21:07:13 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 21:07:13 +0800
commit665a55a1a232877ccb499dbfd17806f438385e82 (patch)
tree657c930823e90fe941e2e7cfab41888ce37c4583 /indra/llmath/CMakeLists.txt
parent6e4f095baa8e33effe80b68ddf834a3b80f2bb67 (diff)
The Linden libraries can be installed now
Useful when installed as shared libraries, so other viewer executables can share these libraries.
Diffstat (limited to 'indra/llmath/CMakeLists.txt')
-rw-r--r--indra/llmath/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/llmath/CMakeLists.txt b/indra/llmath/CMakeLists.txt
index 955bade204..fe13d17fce 100644
--- a/indra/llmath/CMakeLists.txt
+++ b/indra/llmath/CMakeLists.txt
@@ -59,6 +59,7 @@ set(llmath_HEADER_FILES
llmath.h
llmatrix3a.h
llmatrix3a.inl
+ llmatrix4a.h
llmodularmath.h
lloctree.h
llperlin.h
@@ -103,6 +104,8 @@ include_directories(${CMAKE_SOURCE_DIR}/llmeshoptimizer)
target_link_libraries(llmath llcommon)
target_include_directories( llmath INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
+include(LibraryInstall)
+
# Add tests
if (LL_TESTS)
include(LLAddBuildTest)