summaryrefslogtreecommitdiff
path: root/indra/llmath/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 20:58:27 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 20:58:27 +0800
commit6e4f095baa8e33effe80b68ddf834a3b80f2bb67 (patch)
tree3d131c6056d3b6132226ff69da54c11800809a56 /indra/llmath/CMakeLists.txt
parentd74367b40d3a2680bbc371b72e294419093e1d83 (diff)
Setting BUILD_SHARED_LIBS on is now possible
by removing cyclic dependencies, and allowing shlib undefined on SLPlugin alone.
Diffstat (limited to 'indra/llmath/CMakeLists.txt')
-rw-r--r--indra/llmath/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/indra/llmath/CMakeLists.txt b/indra/llmath/CMakeLists.txt
index eb29df245a..955bade204 100644
--- a/indra/llmath/CMakeLists.txt
+++ b/indra/llmath/CMakeLists.txt
@@ -99,7 +99,8 @@ list(APPEND llmath_SOURCE_FILES ${llmath_HEADER_FILES})
add_library (llmath ${llmath_SOURCE_FILES})
-target_link_libraries(llmath llcommon llmeshoptimizer)
+include_directories(${CMAKE_SOURCE_DIR}/llmeshoptimizer)
+target_link_libraries(llmath llcommon)
target_include_directories( llmath INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
# Add tests