summaryrefslogtreecommitdiff
path: root/indra/llkdu/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2016-07-01 14:11:45 -0400
committerNat Goodspeed <nat@lindenlab.com>2016-07-01 14:11:45 -0400
commit8854f5ca29b73f20357c1afeade46e63798923a0 (patch)
tree24e4859334832a0837da629794fc309da587bcc6 /indra/llkdu/CMakeLists.txt
parent1a3fa64ecc3d88f42fb7abb99f854db0a4784b8b (diff)
parent6f6c8fa5ff6619b123f368d9137c11ed679a5349 (diff)
Automated merge with ssh://bitbucket.org/nat_linden/viewer-mac-mainloop
Diffstat (limited to 'indra/llkdu/CMakeLists.txt')
-rw-r--r--indra/llkdu/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/llkdu/CMakeLists.txt b/indra/llkdu/CMakeLists.txt
index b8f8b420c3..cb0e204e91 100644
--- a/indra/llkdu/CMakeLists.txt
+++ b/indra/llkdu/CMakeLists.txt
@@ -40,6 +40,14 @@ set_source_files_properties(${llkdu_HEADER_FILES}
list(APPEND llkdu_SOURCE_FILES ${llkdu_HEADER_FILES})
+# Our KDU package is built with KDU_X86_INTRINSICS in its .vcxproj file.
+# Unless that macro is also set for every consumer build, KDU freaks out,
+# spamming the viewer log with alignment FUD.
+set_source_files_properties(${llkdu_SOURCE_FILES}
+ PROPERTIES
+ COMPILE_DEFINITIONS
+ "KDU_X86_INTRINSICS")
+
if (USE_KDU)
add_library (llkdu ${llkdu_SOURCE_FILES})