summaryrefslogtreecommitdiff
path: root/indra/llkdu/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2011-01-05 17:54:12 -0500
committerOz Linden <oz@lindenlab.com>2011-01-05 17:54:12 -0500
commit1034db639462d95e54e9bf9e4d63500b745bb0a2 (patch)
tree68b010fb3f9f2c4b67e59187d125090b1c69d72f /indra/llkdu/CMakeLists.txt
parent0eb491417e8479516b07cc9237242b60d36d10f5 (diff)
parenteb0b8ab3ea19617a52881191bab21bfedcc5696d (diff)
merge changes for storm-806
Diffstat (limited to 'indra/llkdu/CMakeLists.txt')
-rw-r--r--indra/llkdu/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/indra/llkdu/CMakeLists.txt b/indra/llkdu/CMakeLists.txt
index b8b44b44fc..7ed1c6c694 100644
--- a/indra/llkdu/CMakeLists.txt
+++ b/indra/llkdu/CMakeLists.txt
@@ -42,4 +42,14 @@ list(APPEND llkdu_SOURCE_FILES ${llkdu_HEADER_FILES})
if (USE_KDU)
add_library (${LLKDU_LIBRARIES} ${llkdu_SOURCE_FILES})
+ # Add tests
+ if (LL_TESTS)
+ include(LLAddBuildTest)
+ include(Tut)
+ SET(llkdu_TEST_SOURCE_FILES
+ llimagej2ckdu.cpp
+ )
+ LL_ADD_PROJECT_UNIT_TESTS(llkdu "${llkdu_TEST_SOURCE_FILES}")
+ endif (LL_TESTS)
+
endif (USE_KDU)