summaryrefslogtreecommitdiff
path: root/indra/llkdu/CMakeLists.txt
diff options
context:
space:
mode:
authorMerov Linden <merov@lindenlab.com>2010-11-12 16:37:42 -0800
committerMerov Linden <merov@lindenlab.com>2010-11-12 16:37:42 -0800
commit04adbdad4bb13cb98c77bba17fcc9a16e0f44203 (patch)
treedee9b839cae51f78d26905939340505b1345b582 /indra/llkdu/CMakeLists.txt
parent94f44437d7e7ccb54f227e35523fa8a4e027d7d2 (diff)
STORM-151 : Got decompression to work, compression disabled, simplified llkdu building
Diffstat (limited to 'indra/llkdu/CMakeLists.txt')
-rw-r--r--indra/llkdu/CMakeLists.txt22
1 files changed, 2 insertions, 20 deletions
diff --git a/indra/llkdu/CMakeLists.txt b/indra/llkdu/CMakeLists.txt
index 2806af26c3..0932d368b5 100644
--- a/indra/llkdu/CMakeLists.txt
+++ b/indra/llkdu/CMakeLists.txt
@@ -25,26 +25,12 @@ include_directories(
)
set(llkdu_SOURCE_FILES
- kdc_flow_control.cpp
- kde_flow_control.cpp
- kdu_image.cpp
- llblockdata.cpp
- llblockdecoder.cpp
- llblockencoder.cpp
llimagej2ckdu.cpp
llkdumem.cpp
)
set(llkdu_HEADER_FILES
CMakeLists.txt
-
- kdc_flow_control.h
- kde_flow_control.h
- kdu_image.h
- kdu_image_local.h
- llblockdata.h
- llblockdecoder.h
- llblockencoder.h
llimagej2ckdu.h
llkdumem.h
)
@@ -71,15 +57,11 @@ if (WINDOWS)
endif (WINDOWS)
if (LLKDU_LIBRARY)
- add_library (${LLKDU_STATIC_LIBRARY} ${llkdu_SOURCE_FILES})
+ add_library (${LLKDU_LIBRARY} ${llkdu_SOURCE_FILES})
target_link_libraries(
- ${LLKDU_STATIC_LIBRARY}
-# ${LLIMAGE_LIBRARIES}
-# ${LLVFS_LIBRARIES}
+ ${LLKDU_LIBRARY}
${LLMATH_LIBRARIES}
-# ${LLCOMMON_LIBRARIES}
${KDU_LIBRARY}
-# ${WINDOWS_LIBRARIES}
)
endif (LLKDU_LIBRARY)