summaryrefslogtreecommitdiff
path: root/indra/llinventory/CMakeLists.txt
diff options
context:
space:
mode:
authorAimee Linden <aimee@lindenlab.com>2010-08-18 17:41:36 +0100
committerAimee Linden <aimee@lindenlab.com>2010-08-18 17:41:36 +0100
commit855192a83b908bb2812a6faeeec11da1dcb95cd7 (patch)
tree8b00003a82d5b8b1a7b2412fc96a4102751c3821 /indra/llinventory/CMakeLists.txt
parent5bb7cbc663f77f6e75b8acac7ac4ec1fb346737d (diff)
VWR-20768 (SNOW-507) FIXED Missing LL_TEST conditions in cmake files
Diffstat (limited to 'indra/llinventory/CMakeLists.txt')
-rw-r--r--indra/llinventory/CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/indra/llinventory/CMakeLists.txt b/indra/llinventory/CMakeLists.txt
index a563db901a..6b2b61f883 100644
--- a/indra/llinventory/CMakeLists.txt
+++ b/indra/llinventory/CMakeLists.txt
@@ -59,16 +59,16 @@ list(APPEND llinventory_SOURCE_FILES ${llinventory_HEADER_FILES})
add_library (llinventory ${llinventory_SOURCE_FILES})
+if(LL_TESTS)
+ #add unit tests
+ INCLUDE(LLAddBuildTest)
+ SET(llinventory_TEST_SOURCE_FILES
+ # no real unit tests yet!
+ )
+ LL_ADD_PROJECT_UNIT_TESTS(llinventory "${llinventory_TEST_SOURCE_FILES}")
-#add unit tests
-INCLUDE(LLAddBuildTest)
-SET(llinventory_TEST_SOURCE_FILES
- # no real unit tests yet!
- )
-LL_ADD_PROJECT_UNIT_TESTS(llinventory "${llinventory_TEST_SOURCE_FILES}")
-
-#set(TEST_DEBUG on)
-set(test_libs llinventory ${LLMESSAGE_LIBRARIES} ${LLVFS_LIBRARIES} ${LLMATH_LIBRARIES} ${LLCOMMON_LIBRARIES} ${WINDOWS_LIBRARIES})
-LL_ADD_INTEGRATION_TEST(inventorymisc "" "${test_libs}")
-LL_ADD_INTEGRATION_TEST(llparcel "" "${test_libs}")
-
+ #set(TEST_DEBUG on)
+ set(test_libs llinventory ${LLMESSAGE_LIBRARIES} ${LLVFS_LIBRARIES} ${LLMATH_LIBRARIES} ${LLCOMMON_LIBRARIES} ${WINDOWS_LIBRARIES})
+ LL_ADD_INTEGRATION_TEST(inventorymisc "" "${test_libs}")
+ LL_ADD_INTEGRATION_TEST(llparcel "" "${test_libs}")
+endif(LL_TESTS)