summaryrefslogtreecommitdiff
path: root/indra/llimagej2coj/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Parks <davep@lindenlab.com>2023-03-31 11:57:48 -0500
committerDave Parks <davep@lindenlab.com>2023-03-31 11:57:48 -0500
commit7d144fcb2a1b0aff1b59e378c652649c3d03e94f (patch)
treede3bfe3ce90677cc4d7ab25b8aeaf5853c009068 /indra/llimagej2coj/CMakeLists.txt
parent0fe09bd968b987605123e99efb2fa040a988a942 (diff)
parente4173ea5cc1ef9b1677ac87a0f7c8acbe73414ee (diff)
Merge branch 'DRTVWR-559' of github.com:secondlife/viewer into DRTVWR-559
Diffstat (limited to 'indra/llimagej2coj/CMakeLists.txt')
-rw-r--r--indra/llimagej2coj/CMakeLists.txt16
1 files changed, 4 insertions, 12 deletions
diff --git a/indra/llimagej2coj/CMakeLists.txt b/indra/llimagej2coj/CMakeLists.txt
index c9423d50dd..93e85668dd 100644
--- a/indra/llimagej2coj/CMakeLists.txt
+++ b/indra/llimagej2coj/CMakeLists.txt
@@ -7,12 +7,6 @@ include(LLCommon)
include(LLImage)
include(OpenJPEG)
-include_directories(
- ${LLCOMMON_INCLUDE_DIRS}
- ${LLIMAGE_INCLUDE_DIRS}
- ${OPENJPEG_INCLUDE_DIR}
- )
-
set(llimagej2coj_SOURCE_FILES
llimagej2coj.cpp
)
@@ -23,15 +17,13 @@ set(llimagej2coj_HEADER_FILES
llimagej2coj.h
)
-set_source_files_properties(${llimagej2coj_HEADER_FILES}
- PROPERTIES HEADER_FILE_ONLY TRUE)
-
list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES})
add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES})
-target_link_libraries(
- llimagej2coj
- ${OPENJPEG_LIBRARIES}
+target_link_libraries( llimagej2coj
+ llcommon
+ llimage
+ ll::openjpeg
)