summaryrefslogtreecommitdiff
path: root/indra/llimage/CMakeLists.txt
diff options
context:
space:
mode:
authorMerov Linden <merov@lindenlab.com>2010-12-17 11:30:52 -0800
committerMerov Linden <merov@lindenlab.com>2010-12-17 11:30:52 -0800
commit922f4e59ab2ab58192f9e8832b14fe7a63ee8fd8 (patch)
tree3033da4b74179b0c20efd42f0dc157ddd2f58e79 /indra/llimage/CMakeLists.txt
parent71fa0894981bacd26ed07b8a8ab542dcaf2e7ae2 (diff)
STORM-744 : Turn llimage/tests/ on again
Diffstat (limited to 'indra/llimage/CMakeLists.txt')
-rw-r--r--indra/llimage/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/indra/llimage/CMakeLists.txt b/indra/llimage/CMakeLists.txt
index 6834267d4b..ea8c1a1107 100644
--- a/indra/llimage/CMakeLists.txt
+++ b/indra/llimage/CMakeLists.txt
@@ -3,12 +3,13 @@
project(llimage)
include(00-Common)
-include(LLAddBuildTest)
include(LLCommon)
include(LLImage)
include(LLMath)
include(LLVFS)
include(ZLIB)
+include(LLAddBuildTest)
+include(Tut)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
@@ -63,4 +64,12 @@ target_link_libraries(llimage
)
# Add tests
-#ADD_BUILD_TEST(llimageworker llimage)
+if (LL_TESTS)
+ SET(llimage_TEST_SOURCE_FILES
+ llimageworker.cpp
+ )
+ LL_ADD_PROJECT_UNIT_TESTS(llimage "${llimage_TEST_SOURCE_FILES}")
+endif (LL_TESTS)
+
+
+