summaryrefslogtreecommitdiff
path: root/indra/llfilesystem/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-12-18 20:42:30 +0800
committerErik Kundiman <erik@megapahit.org>2023-12-18 20:42:30 +0800
commitb0e28d27bd990393e22ca3f474c340e77a08357b (patch)
tree31698ce16af0883d128cb4cc804c25f85650c711 /indra/llfilesystem/CMakeLists.txt
parentee89162c037d693d63376762b417049f5f066672 (diff)
Unix install sets plugin dir to system library dir
because (at least) the vlc/plugins dirs are inside it in the same way it's been inside llplugin. This is so the app can find system VLC plugins. And for this, BUILD_SHARED_LIBS set on must work first on Linux (has already been working on FreeBSD), since libmedia_plugin_libvlc is a shared library (which now gets installed to system library dir too, on both OSes).
Diffstat (limited to 'indra/llfilesystem/CMakeLists.txt')
-rw-r--r--indra/llfilesystem/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/indra/llfilesystem/CMakeLists.txt b/indra/llfilesystem/CMakeLists.txt
index 9a69a833c0..7db1971460 100644
--- a/indra/llfilesystem/CMakeLists.txt
+++ b/indra/llfilesystem/CMakeLists.txt
@@ -37,7 +37,7 @@ if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
if (INSTALL)
set_source_files_properties(lldir_linux.cpp
PROPERTIES COMPILE_FLAGS
- "-DAPP_RO_DATA_DIR=\\\"${APP_SHARE_DIR}\\\" -DAPP_LIBEXEC_DIR=\\\"${APP_LIBEXEC_DIR}\\\""
+ "-DAPP_RO_DATA_DIR=\\\"${APP_SHARE_DIR}\\\" -DAPP_LIBEXEC_DIR=\\\"${APP_LIBEXEC_DIR}\\\" -DAPP_PLUGIN_DIR=\\\"${INSTALL_LIBRARY_DIR}\\\""
)
endif (INSTALL)
endif (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")