summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authornat-goodspeed <nat@lindenlab.com>2024-02-08 14:45:43 -0500
committerGitHub <noreply@github.com>2024-02-08 14:45:43 -0500
commit24b6059620698744c035474db93975ebac28e45b (patch)
tree5437fa6948a8a111b77b8bcf726629d419cdcf1d /indra/llcommon/CMakeLists.txt
parenteb0c19b2746890eb4dbfd6eac045699d0e5842dd (diff)
parent4e9794bd06660baea6d16779f6e354ca99e11b8a (diff)
Merge pull request #21 from secondlife/lua_function
Break out lua_function.h to enable decentralizing Lua entry points to C++.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 5f4ed2fffa..990d661e38 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -107,6 +107,8 @@ set(llcommon_SOURCE_FILES
lluriparser.cpp
lluuid.cpp
llworkerthread.cpp
+ lua_function.cpp
+ lualistener.cpp
hbxxh.cpp
u64.cpp
threadpool.cpp
@@ -249,6 +251,8 @@ set(llcommon_HEADER_FILES
llwin32headers.h
llwin32headerslean.h
llworkerthread.h
+ lua_function.h
+ lualistener.h
hbxxh.h
lockstatic.h
stdtypes.h