summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authornat-goodspeed <nat@lindenlab.com>2024-09-05 14:30:27 -0400
committerGitHub <noreply@github.com>2024-09-05 14:30:27 -0400
commit18d81e20f0b0044c16615953d7b69d7fb34d3449 (patch)
tree2b3f02ad060c0f4a55f2ff8b3ec53dc3f3b8f60b /indra/llcommon/CMakeLists.txt
parent7ac4c3b56e5246fceaa73e7c9c665d3c04827d6c (diff)
parent49bf86b52459b183d3988388dbb74d8888a71925 (diff)
Merge pull request #2451 from secondlife/lua-resultset
Give certain `LLInventoryListener` queries an API based on result sets.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 22cc22abba..3b157fd28f 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -111,6 +111,7 @@ set(llcommon_SOURCE_FILES
lockstatic.cpp
lua_function.cpp
lualistener.cpp
+ resultset.cpp
threadpool.cpp
throttle.cpp
u64.cpp
@@ -189,6 +190,7 @@ set(llcommon_HEADER_FILES
llinitparam.h
llinstancetracker.h
llinstancetrackersubclass.h
+ llinttracker.h
llkeybind.h
llkeythrottle.h
llleap.h
@@ -261,6 +263,7 @@ set(llcommon_HEADER_FILES
lockstatic.h
lua_function.h
lualistener.h
+ resultset.h
stdtypes.h
stringize.h
tempset.h