summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Palange (Mani) <palange@lindenlab.com>2009-11-06 10:53:51 -0800
committerMark Palange (Mani) <palange@lindenlab.com>2009-11-06 10:53:51 -0800
commit05baf9940bd8e9491c4cc7fb426d8e56f50e4d22 (patch)
tree5c512c356b703da68dab533cfd652b261b17c784 /indra/llcommon/CMakeLists.txt
parent258eb3d7dd298390eca2740dc3c18c7c454df5e0 (diff)
parent953b7ea550bb59f5ebc12c0dfc4e0a454da4f601 (diff)
merge
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index f785698612..ea36e65729 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -8,9 +8,7 @@ include(Linking)
include(Boost)
include (Pth)
-if (WINDOWS)
- include(CopyWinLibs)
-endif (WINDOWS)
+include(Copy3rdPartyLibs)
include_directories(
${EXPAT_INCLUDE_DIRS}
@@ -252,6 +250,13 @@ if(LLCOMMON_LINK_SHARED)
if(NOT WINDOWS)
get_target_property(LLCOMMON_PATH llcommon LOCATION)
get_filename_component(LLCOMMON_FILE ${LLCOMMON_PATH} NAME)
+ if(DARWIN)
+ set(SHARED_LIB_STAGING_DIR_CONFIG ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/Resources)
+ else(DARWIN)
+ set(SHARED_LIB_STAGING_DIR_CONFIG ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR})
+ endif(DARWIN)
+
+ # *TODO - maybe make this a symbolic link? -brad
add_custom_command(
TARGET llcommon POST_BUILD
COMMAND ${CMAKE_COMMAND}
@@ -259,7 +264,7 @@ if(LLCOMMON_LINK_SHARED)
-E
copy_if_different
${LLCOMMON_PATH}
- ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/${LLCOMMON_FILE}
+ ${SHARED_LIB_STAGING_DIR_CONFIG}/${LLCOMMON_FILE}
COMMENT "Copying llcommon to the staging folder."
)
endif(NOT WINDOWS)