summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorEuclid Linden <euclid@lindenlab.com>2021-07-19 21:52:37 +0000
committerEuclid Linden <euclid@lindenlab.com>2021-07-19 21:52:37 +0000
commit08f04113c9252258c9cb6132efa327432c3c27e0 (patch)
tree5ec6c6d42eaca354f58e21b926d9108e43367484 /indra/llcommon/CMakeLists.txt
parent10f84d8244d01728338f1eb20b0b25271fc7db63 (diff)
parentaa322d8eb4341c213a19cef87a887114c1ca278b (diff)
Merged in DV541-merge-6.4.22 (pull request #629)
DRTVWR-541 merge up to v 6.4.22
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index cecfadcd91..dd266630ea 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -4,6 +4,7 @@ project(llcommon)
include(00-Common)
include(LLCommon)
+include(bugsplat)
include(Linking)
include(Boost)
include(LLSharedLibs)
@@ -260,10 +261,10 @@ set(llcommon_HEADER_FILES
set_source_files_properties(${llcommon_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
-if (BUGSPLAT_DB)
- set_source_files_properties(llapp.cpp
- PROPERTIES COMPILE_DEFINITIONS "LL_BUGSPLAT")
-endif (BUGSPLAT_DB)
+if (USE_BUGSPLAT)
+ set_source_files_properties(${llcommon_SOURCE_FILES}
+ PROPERTIES COMPILE_DEFINITIONS "${BUGSPLAT_DEFINE}")
+endif (USE_BUGSPLAT)
list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})