summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2009-06-19 00:17:30 +0000
committerNat Goodspeed <nat@lindenlab.com>2009-06-19 00:17:30 +0000
commitdc3833f31b8a20220ddb1775e1625c016c397435 (patch)
tree166ce57be2578ea03d1e20976977e4ca6c1f1dba /indra/llcommon/CMakeLists.txt
parent8a8edfd98c7fced23f4c1f8dd5e4f65e1cadfce8 (diff)
DEV-31980: extract dispatch-by-string-name logic from LLAresListener to new
LLEventDispatcher and LLDispatchListener classes. See LLAresListener for example usage.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index e920475f54..88acb70b8a 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -37,6 +37,7 @@ set(llcommon_SOURCE_FILES
llerrorthread.cpp
llevent.cpp
lleventcoro.cpp
+ lleventdispatcher.cpp
lleventfilter.cpp
llevents.cpp
llfasttimer.cpp
@@ -126,6 +127,7 @@ set(llcommon_HEADER_FILES
llerrorthread.h
llevent.h
lleventcoro.h
+ lleventdispatcher.h
lleventfilter.h
llevents.h
lleventemitter.h