summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 21:07:13 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 21:07:13 +0800
commit665a55a1a232877ccb499dbfd17806f438385e82 (patch)
tree657c930823e90fe941e2e7cfab41888ce37c4583 /indra/llcommon/CMakeLists.txt
parent6e4f095baa8e33effe80b68ddf834a3b80f2bb67 (diff)
The Linden libraries can be installed now
Useful when installed as shared libraries, so other viewer executables can share these libraries.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 758d746d54..ed7ac8deb7 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -158,6 +158,7 @@ set(llcommon_HEADER_FILES
lleventdispatcher.h
lleventfilter.h
llevents.h
+ lleventtimer.h
lleventemitter.h
llexception.h
llfasttimer.h
@@ -181,12 +182,14 @@ set(llcommon_HEADER_FILES
llliveappconfig.h
lllivefile.h
llmainthreadtask.h
+ llmake.h
llmd5.h
llmemory.h
llmemorystream.h
llmetrics.h
llmetricperformancetester.h
llmortician.h
+ llmutex.h
llnametable.h
llpointer.h
llprofiler.h
@@ -243,7 +246,9 @@ set(llcommon_HEADER_FILES
llwin32headerslean.h
llworkerthread.h
hbxxh.h
+ is_approx_equal_fraction.h
lockstatic.h
+ mutex.h
stdtypes.h
stringize.h
threadpool.h
@@ -289,6 +294,8 @@ else ()
endif()
endif ()
+include(LibraryInstall)
+
if (LL_TESTS)
include(LLAddBuildTest)
SET(llcommon_TEST_SOURCE_FILES