summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad Payne (Vir Linden) <vir@lindenlab.com>2016-01-26 08:23:40 -0500
committerBrad Payne (Vir Linden) <vir@lindenlab.com>2016-01-26 08:23:40 -0500
commit5345d1e115fdf3fca7ea3e8330f1a23ad19257c8 (patch)
tree6614014a8a794b6d15f075bbf76511309ee272ee /indra/llcommon/CMakeLists.txt
parent4d29ff4fb6f68e27a6376fe52d81f8a4a95f5633 (diff)
SL-315 WIP - added a call stack extractor for windows to help with tracing joint issues (of course, could be used for other things as well).
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rwxr-xr-xindra/llcommon/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 5863310162..635344bc4b 100755
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -38,6 +38,7 @@ set(llcommon_SOURCE_FILES
llbase64.cpp
llbitpack.cpp
llcallbacklist.cpp
+ llcallstack.cpp
llcommon.cpp
llcommonutils.cpp
llcoros.cpp
@@ -111,6 +112,7 @@ set(llcommon_SOURCE_FILES
llworkerthread.cpp
timing.cpp
u64.cpp
+ StackWalker.cpp
)
set(llcommon_HEADER_FILES
@@ -131,6 +133,7 @@ set(llcommon_HEADER_FILES
llbitpack.h
llboost.h
llcallbacklist.h
+ llcallstack.h
llcommon.h
llcommonutils.h
llcoros.h
@@ -231,6 +234,7 @@ set(llcommon_HEADER_FILES
stringize.h
timer.h
u64.h
+ StackWalker.h
)
set_source_files_properties(${llcommon_HEADER_FILES}