summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorcallum_linden <callum@lindenlab.com>2017-10-24 16:13:23 -0700
committercallum_linden <callum@lindenlab.com>2017-10-24 16:13:23 -0700
commit2e3c5ac88a434ee437bc3e68b321d5bd0bcd7cc9 (patch)
tree115211548527d20842c10c87eb013a45578c4632 /indra/llcommon/CMakeLists.txt
parentd359dca06518d778c0f115afec8c759ca026de47 (diff)
Add in real SL viewer name and version
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 50e262ae7a..9c5481a977 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -14,6 +14,7 @@ include(Copy3rdPartyLibs)
include(ZLIB)
include(URIPARSER)
include(BUGSPLAT)
+include(BuildVersion)
include_directories(
${EXPAT_INCLUDE_DIRS}
@@ -255,7 +256,14 @@ set(llcommon_HEADER_FILES
)
set_source_files_properties(${llcommon_HEADER_FILES}
- PROPERTIES HEADER_FILE_ONLY TRUE)
+ PROPERTIES HEADER_FILE_ONLY TRUE
+ )
+
+# bring in version information for BugSplat crash reporting
+set_source_files_properties(${llcommon_SOURCE_FILES}
+ PROPERTIES
+ COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}" # see BuildVersion.cmake
+ )
list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})