summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2023-07-27 12:21:05 -0400
committerNat Goodspeed <nat@lindenlab.com>2023-07-27 12:21:05 -0400
commit1cebf95f13aecf6050cde296bce6696ba791378b (patch)
treef8fc3caad7bc47b949ba65150ba8c3b7b0e4fe77 /indra/llcommon/CMakeLists.txt
parent2159da95e0acc15daa7ab18bc17f1d5f60be71cc (diff)
DRTVWR-587: Disable LazyEventAPI tests on TeamCity Macs.
There's a limit to how much time it's worth trying to work around a compiler bug that's already been fixed in newer Xcode.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index e02f69126e..0df113e2c8 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -298,7 +298,13 @@ if (LL_TESTS)
LL_ADD_INTEGRATION_TEST(bitpack "" "${test_libs}")
LL_ADD_INTEGRATION_TEST(classic_callback "" "${test_libs}")
LL_ADD_INTEGRATION_TEST(commonmisc "" "${test_libs}")
- LL_ADD_INTEGRATION_TEST(lazyeventapi "" "${test_libs}")
+ if (WINDOWS)
+ # As of 2023-07-27, lazyeventapi.h triggers a bug in older clang,
+ # unfortunately the version we run on our TeamCity Mac build agent. As we
+ # move forward, either with an updated TC agent or GitHub builds, remove
+ # this 'if'.
+ LL_ADD_INTEGRATION_TEST(lazyeventapi "" "${test_libs}")
+ endif ()
LL_ADD_INTEGRATION_TEST(llbase64 "" "${test_libs}")
LL_ADD_INTEGRATION_TEST(llcond "" "${test_libs}")
LL_ADD_INTEGRATION_TEST(lldate "" "${test_libs}")