summaryrefslogtreecommitdiff
path: root/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorcallum_linden <none@none>2013-02-01 08:44:52 -0800
committercallum_linden <none@none>2013-02-01 08:44:52 -0800
commitb0f2f02333a87598299b490a1e42eb42a8125f74 (patch)
tree8d1fe612b4ca516a3b8c97caa73efa1f9e836275 /indra/llaudio/CMakeLists.txt
parent9b86b8bf3d822bbeefb8518fb335e81a6dc7f3b3 (diff)
Removed (most) references to older FMOD library - still a little Linux clean up left
Diffstat (limited to 'indra/llaudio/CMakeLists.txt')
-rw-r--r--indra/llaudio/CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/indra/llaudio/CMakeLists.txt b/indra/llaudio/CMakeLists.txt
index b2d7b7c911..f27bcb27d1 100644
--- a/indra/llaudio/CMakeLists.txt
+++ b/indra/llaudio/CMakeLists.txt
@@ -6,7 +6,6 @@ include(00-Common)
include(Audio)
include(LLAudio)
include(FMODEX)
-set(FMOD OFF)
include(OPENAL)
include(LLCommon)
include(LLMath)
@@ -61,30 +60,6 @@ if (FMODEX)
)
endif (FMODEX)
-if (FMOD)
- include_directories(
- ${FMOD_INCLUDE_DIR}
- )
-
- list(APPEND llaudio_SOURCE_FILES
- llaudioengine_fmod.cpp
- lllistener_fmod.cpp
- llstreamingaudio_fmod.cpp
- )
-
- list(APPEND llaudio_HEADER_FILES
- llaudioengine_fmod.h
- lllistener_fmod.h
- llstreamingaudio_fmod.h
- )
-
- if (LINUX OR DARWIN)
- set_source_files_properties(llaudioengine_fmod.cpp
- llstreamingaudio_fmod.cpp
- COMPILE_FLAGS -Wno-write-strings)
- endif (LINUX OR DARWIN)
-endif (FMOD)
-
if (OPENAL)
list(APPEND llaudio_SOURCE_FILES
llaudioengine_openal.cpp