summaryrefslogtreecommitdiff
path: root/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorLynx Linden <lynx@lindenlab.com>2009-11-30 18:42:45 +0000
committerLynx Linden <lynx@lindenlab.com>2009-11-30 18:42:45 +0000
commitdcc617fcf5b5b0b84df4b9040693ed872e7abb4f (patch)
tree9039b39cd77f4b9b067056902ae219bf7bd6edd2 /indra/llaudio/CMakeLists.txt
parent5bff5d28ee0cd6b2d17bf1676eecb0ae262f1f48 (diff)
Made the gcc version number checking more robust in llaudio's
CMakeFiles.txt file. Previously it checked for a narrow range of gcc versions via a regex: if (${CXX_VERSION} MATCHES "4.[23]") Now we explicit check for any version >= 4.2: if (${CXX_VERSION_NUMBER} GREATER 419)
Diffstat (limited to 'indra/llaudio/CMakeLists.txt')
-rw-r--r--indra/llaudio/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/indra/llaudio/CMakeLists.txt b/indra/llaudio/CMakeLists.txt
index 9e9e1aaeae..9a281926bf 100644
--- a/indra/llaudio/CMakeLists.txt
+++ b/indra/llaudio/CMakeLists.txt
@@ -60,11 +60,11 @@ if (FMOD)
)
if (LINUX)
- if (${CXX_VERSION} MATCHES "4.[23]")
+ if (${CXX_VERSION_NUMBER} GREATER 419)
set_source_files_properties(llaudioengine_fmod.cpp
llstreamingaudio_fmod.cpp
COMPILE_FLAGS -Wno-write-strings)
- endif (${CXX_VERSION} MATCHES "4.[23]")
+ endif (${CXX_VERSION_NUMBER} GREATER 419)
endif (LINUX)
endif (FMOD)