summaryrefslogtreecommitdiff
path: root/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Kleshchev <andreykproductengine@lindenlab.com>2024-02-01 23:00:53 +0200
committerAndrey Kleshchev <117672381+akleshchev@users.noreply.github.com>2024-02-09 01:31:50 +0200
commit762855f2554393dd3bcacd9b5d205765409f6a95 (patch)
tree21d57c479032ce094108564e595d2f31f6c7a876 /indra/llaudio/CMakeLists.txt
parent4cec3133197cd39efd607b82169a85f56c77aa68 (diff)
SL-19585 Try replacing fmod with openal
Since now VLC is responsible for played parcel media (should be since SL-19042) should be possible to switch remaining audio to OpenAL with no loss of functionality
Diffstat (limited to 'indra/llaudio/CMakeLists.txt')
-rw-r--r--indra/llaudio/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/indra/llaudio/CMakeLists.txt b/indra/llaudio/CMakeLists.txt
index 4f469b9bb5..9278d3c488 100644
--- a/indra/llaudio/CMakeLists.txt
+++ b/indra/llaudio/CMakeLists.txt
@@ -4,7 +4,6 @@ project(llaudio)
include(00-Common)
include(LLAudio)
-include(FMODSTUDIO)
include(OPENAL)
include(LLCommon)
@@ -25,20 +24,6 @@ set(llaudio_HEADER_FILES
llwindgen.h
)
-if (TARGET ll::fmodstudio)
- list(APPEND llaudio_SOURCE_FILES
- llaudioengine_fmodstudio.cpp
- lllistener_fmodstudio.cpp
- llstreamingaudio_fmodstudio.cpp
- )
-
- list(APPEND llaudio_HEADER_FILES
- llaudioengine_fmodstudio.h
- lllistener_fmodstudio.h
- llstreamingaudio_fmodstudio.h
- )
-endif ()
-
if (TARGET ll::openal)
list(APPEND llaudio_SOURCE_FILES
llaudioengine_openal.cpp