summaryrefslogtreecommitdiff
path: root/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-13 19:21:55 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-13 19:21:55 +0200
commit241919e7f7986c11586a49bff53cf19c2c0e0ea6 (patch)
treedfd7f4fa971fd77c89eaaa140ba1e53b910b24aa /indra/llaudio/CMakeLists.txt
parent2c9ede0ccc3b6a27ca418fcb6e7a91eb87b261e9 (diff)
Rework cmake, the original plan was to maybe be able to use conan targets with the same name (that's why 3ps had names like apr::apr),
but it's safer and saner to put the LL 3ps under the ll:: prefix. This also allows means it is possible to get rid of that bad "if( TRAGET ...) return() endif()" pattern and rather use include_guard().
Diffstat (limited to 'indra/llaudio/CMakeLists.txt')
-rw-r--r--indra/llaudio/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/indra/llaudio/CMakeLists.txt b/indra/llaudio/CMakeLists.txt
index 16576ddbad..21e4723e7e 100644
--- a/indra/llaudio/CMakeLists.txt
+++ b/indra/llaudio/CMakeLists.txt
@@ -63,12 +63,12 @@ target_link_libraries( llaudio
llmath
llmessage
llfilesystem
- vorbis::vorbis
+ ll::vorbis
)
-if( TARGET openal::openal )
- target_link_libraries( llaudio openal::openal )
+if( TARGET ll::openal )
+ target_link_libraries( llaudio ll::openal )
endif()
-if( TARGET fmodstudio::fmodstudio )
- target_link_libraries( llaudio fmodstudio::fmodstudio )
+if( TARGET ll::fmodstudio )
+ target_link_libraries( llaudio ll::fmodstudio )
endif() \ No newline at end of file