summaryrefslogtreecommitdiff
path: root/indra/copy_win_scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
commit9db949eec327df4173fde3de934a87bedb0db13c (patch)
treeaeffa0f0e68b1d2ceb74d460cbbd22652c9cd159 /indra/copy_win_scripts/CMakeLists.txt
parent419e13d0acaabf5e1e02e9b64a07648bce822b2f (diff)
svn merge -r88066:88786 svn+ssh://svn.lindenlab.com/svn/linden/branches/cmake-9-merge
dataserver-is-deprecated for-fucks-sake-whats-with-these-commit-markers
Diffstat (limited to 'indra/copy_win_scripts/CMakeLists.txt')
-rw-r--r--indra/copy_win_scripts/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/indra/copy_win_scripts/CMakeLists.txt b/indra/copy_win_scripts/CMakeLists.txt
new file mode 100644
index 0000000000..b1b1006e56
--- /dev/null
+++ b/indra/copy_win_scripts/CMakeLists.txt
@@ -0,0 +1,35 @@
+# -*- cmake -*-
+
+# The copy_win_scripts folder contains scripts handy for launching the
+# from the windows command line on windows.
+# The cmake target created copies the scripts to the
+# build directory being used, which where the scripts
+# need to be executed from.
+
+include(CMakeCopyIfDifferent)
+
+set(win_scripts-src ${CMAKE_SOURCE_DIR}/copy_win_scripts)
+set(win_scripts-dst ${CMAKE_BINARY_DIR}/batch)
+
+set(file-list
+ llstart.py
+ start-client.py
+ start-servers.py
+ stop-servers.py
+ user_config.py
+ )
+
+foreach(file ${file-list})
+ if(EXISTS ${file})
+ set(win_scripts-files ${win_scripts-files} file)
+ endif(EXISTS ${file})
+endforeach(file ${file-list})
+
+copy_if_different(
+ ${win_scripts-src}
+ ${win_scripts-dst}
+ win_scripts-targets
+ ${win_scripts-files}
+ )
+
+add_custom_target(copy_win_scripts ALL DEPENDS ${win_scripts-targets})