summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2019-03-02 11:58:11 -0500
committerOz Linden <oz@lindenlab.com>2019-03-02 11:58:11 -0500
commite409c0492f1b1ce63606c0b693c92cdb36dcc28b (patch)
tree1b74701425dad859b4eb8e01593af79848dc323c /indra/CMakeLists.txt
parentfc90cad4f366c4bb85add832a2fa8137b1f120ff (diff)
convert to an explicit USE_BUGSPLAT switch in cmake, revise LL_ERRS approach
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 62a8f3f003..cf6029c4ae 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -13,6 +13,7 @@ project(${ROOT_PROJECT_NAME})
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
+include(bugsplat)
include(BuildVersion)
if (NOT CMAKE_BUILD_TYPE)
@@ -89,6 +90,15 @@ set_property(
PROPERTY VS_STARTUP_PROJECT secondlife-bin
)
+if (USE_BUGSPLAT)
+ if (BUGSPLAT_DB)
+ message(STATUS "Building with BugSplat; database '${BUGSPLAT_DB}'")
+ else (BUGSPLAT_DB)
+ message(WARNING "Building with BugSplat, but no database name set (BUGSPLAT_DB)")
+ endif (BUGSPLAT_DB)
+else (USE_BUGSPLAT)
+ message(STATUS "Not building with BugSplat")
+endif (USE_BUGSPLAT)
if (LL_TESTS)
# Define after the custom targets are created so
# individual apps can add themselves as dependencies