summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad Payne (Vir Linden) <vir@lindenlab.com>2020-07-22 17:51:10 +0100
committerBrad Payne (Vir Linden) <vir@lindenlab.com>2020-07-22 17:51:10 +0100
commit6037847ea133c6faed0ff4bea023d72f5799d9e1 (patch)
tree4153ae1af4b074b9bd3cd9a0d84fc2b429a909f3 /indra/CMakeLists.txt
parenta9ddf20ff2c704d30ec4b4d8652da0b0775b7631 (diff)
parent72423372d6cd7f763a5567ad75752fa4e7131d60 (diff)
Merge remote-tracking branch 'origin/master' into SL-12995
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 62a8f3f003..53e5d7b6a5 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -15,6 +15,11 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
include(BuildVersion)
+set(LEGACY_STDIO_LIBS)
+if (WINDOWS)
+ set(LEGACY_STDIO_LIBS legacy_stdio_definitions)
+endif (WINDOWS)
+
if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
"Build type. One of: Debug Release RelWithDebInfo" FORCE)