summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle McKay <scot@lindenlab.com>2008-07-26 18:21:31 +0000
committerKyle McKay <scot@lindenlab.com>2008-07-26 18:21:31 +0000
commit1bb86fb755b99fa58f607b4dcf47c1466664d5ff (patch)
treed66a4c405eaa4045254d90d604f679c155eed50d /indra/CMakeLists.txt
parente79f766f572f6540db4d09d8ffdc61e6daff66d0 (diff)
CMake updates:
1. Initial compatibility with CMake 2.6 (verified on Mac OS X, other platforms may need more work) 2. Ability to more easily debug problems fetching prebuilt libraries (./develop.py configure -DDEBUG_PREBUILT=1) 3. Compatibility with Mac OS X MacPorts/Fink installations by trying to find and use system python executable first
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index db338508a3..f93087f4a0 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -1,10 +1,20 @@
# -*- cmake -*-
-project(SecondLife)
+# cmake_minimum_required should appear before any
+# other commands to guarantee full compatibility
+# with the version specified
# The FindPkgConfig module was released with 2.4.7.
cmake_minimum_required(VERSION 2.4.7 FATAL_ERROR)
+# This makes cmake 2.6 not complain about a version
+# 2.4 compatibility mode
+if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 OLD)
+endif(COMMAND cmake_policy)
+
+project(SecondLife)
+
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)