summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Kjer <don@lindenlab.com>2012-10-04 03:12:48 +0000
committerDon Kjer <don@lindenlab.com>2012-10-04 03:12:48 +0000
commitc9ab9590aa1d44ea139b16e7ffcb1461d928bdd5 (patch)
treec735cd065521eb5b2d719f78e1685c090b265ea6 /indra/CMakeLists.txt
parent8c0aa31536c447edb6ef4fbee43f99debf593a20 (diff)
Removing server-related cmake cruft. Fixing libGLU warnings on linux.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt121
1 files changed, 59 insertions, 62 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index f5ed9632fa..9ea611df6c 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -63,73 +63,70 @@ if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts)
endif (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts)
add_custom_target(viewer)
-if (VIEWER)
- add_subdirectory(${LIBS_OPEN_PREFIX}llcrashlogger)
- add_subdirectory(${LIBS_OPEN_PREFIX}llplugin)
- add_subdirectory(${LIBS_OPEN_PREFIX}llui)
- add_subdirectory(${LIBS_OPEN_PREFIX}viewer_components)
-
- # Legacy C++ tests. Build always, run if LL_TESTS is true.
- add_subdirectory(${VIEWER_PREFIX}test)
-
- # viewer media plugins
- add_subdirectory(${LIBS_OPEN_PREFIX}media_plugins)
-
- # llplugin testbed code (is this the right way to include it?)
- if (LL_TESTS AND NOT LINUX)
- add_subdirectory(${VIEWER_PREFIX}test_apps/llplugintest)
- endif (LL_TESTS AND NOT LINUX)
-
- if (LINUX)
- add_subdirectory(${VIEWER_PREFIX}linux_crash_logger)
- add_subdirectory(${VIEWER_PREFIX}linux_updater)
- if (INSTALL_PROPRIETARY)
- include(LLAppearanceUtility)
- add_subdirectory(${LLAPPEARANCEUTILITY_SRC_DIR} ${LLAPPEARANCEUTILITY_BIN_DIR})
- endif (INSTALL_PROPRIETARY)
- add_dependencies(viewer linux-crash-logger-strip-target linux-updater)
- elseif (DARWIN)
- add_subdirectory(${VIEWER_PREFIX}mac_crash_logger)
- add_subdirectory(${VIEWER_PREFIX}mac_updater)
- add_dependencies(viewer mac-updater mac-crash-logger)
- elseif (WINDOWS)
- add_subdirectory(${VIEWER_PREFIX}win_crash_logger)
- # cmake EXISTS requires an absolute path, see indra/cmake/Variables.cmake
- if (EXISTS ${VIEWER_DIR}win_setup)
- add_subdirectory(${VIEWER_DIR}win_setup)
- endif (EXISTS ${VIEWER_DIR}win_setup)
- add_subdirectory(${VIEWER_PREFIX}win_updater)
- # add_dependencies(viewer windows-updater windows-setup windows-crash-logger)
- add_dependencies(viewer windows-updater windows-crash-logger)
- elseif (SOLARIS)
- add_subdirectory(solaris_crash_logger)
- add_dependencies(viewer solaris-crash-logger)
- endif (LINUX)
-
- add_subdirectory(${VIEWER_PREFIX}newview)
- add_dependencies(viewer secondlife-bin)
-endif (VIEWER)
+add_subdirectory(${LIBS_OPEN_PREFIX}llcrashlogger)
+add_subdirectory(${LIBS_OPEN_PREFIX}llplugin)
+add_subdirectory(${LIBS_OPEN_PREFIX}llui)
+add_subdirectory(${LIBS_OPEN_PREFIX}viewer_components)
+
+# Legacy C++ tests. Build always, run if LL_TESTS is true.
+add_subdirectory(${VIEWER_PREFIX}test)
+
+# viewer media plugins
+add_subdirectory(${LIBS_OPEN_PREFIX}media_plugins)
+
+# llplugin testbed code (is this the right way to include it?)
+if (LL_TESTS AND NOT LINUX)
+ add_subdirectory(${VIEWER_PREFIX}test_apps/llplugintest)
+endif (LL_TESTS AND NOT LINUX)
+
+if (LINUX)
+ add_subdirectory(${VIEWER_PREFIX}linux_crash_logger)
+ add_subdirectory(${VIEWER_PREFIX}linux_updater)
+ if (INSTALL_PROPRIETARY)
+ include(LLAppearanceUtility)
+ add_subdirectory(${LLAPPEARANCEUTILITY_SRC_DIR} ${LLAPPEARANCEUTILITY_BIN_DIR})
+ endif (INSTALL_PROPRIETARY)
+ add_dependencies(viewer linux-crash-logger-strip-target linux-updater)
+elseif (DARWIN)
+ add_subdirectory(${VIEWER_PREFIX}mac_crash_logger)
+ add_subdirectory(${VIEWER_PREFIX}mac_updater)
+ add_dependencies(viewer mac-updater mac-crash-logger)
+elseif (WINDOWS)
+ add_subdirectory(${VIEWER_PREFIX}win_crash_logger)
+ # cmake EXISTS requires an absolute path, see indra/cmake/Variables.cmake
+ if (EXISTS ${VIEWER_DIR}win_setup)
+ add_subdirectory(${VIEWER_DIR}win_setup)
+ endif (EXISTS ${VIEWER_DIR}win_setup)
+ add_subdirectory(${VIEWER_PREFIX}win_updater)
+ # add_dependencies(viewer windows-updater windows-setup windows-crash-logger)
+ add_dependencies(viewer windows-updater windows-crash-logger)
+elseif (SOLARIS)
+ add_subdirectory(solaris_crash_logger)
+ add_dependencies(viewer solaris-crash-logger)
+endif (LINUX)
+
+add_subdirectory(${VIEWER_PREFIX}newview)
+add_dependencies(viewer secondlife-bin)
# Linux builds the viewer and server in 2 separate projects
# In order for build server to work on linux,
# the viewer project needs a server target.
# This is not true for mac and windows.
-if (LINUX)
- add_custom_target(server)
-endif (LINUX)
-if (SERVER)
- if (NOT LINUX)
- add_custom_target(server)
- endif (NOT LINUX)
- include(${SERVER_PREFIX}Server.cmake)
-endif (SERVER)
-
-# Windows builds include tools like VFS tool
-if (SERVER)
- if (WINDOWS)
- add_subdirectory(${SERVER_PREFIX}tools)
- endif (WINDOWS)
-endif (SERVER)
+# *TODO: Do something like this for BAKING?
+#if (LINUX)
+# add_custom_target(server)
+#endif (LINUX)
+#if (SERVER)
+# if (NOT LINUX)
+# add_custom_target(server)
+# endif (NOT LINUX)
+# include(${SERVER_PREFIX}Server.cmake)
+#
+# # Windows builds include tools like VFS tool
+# if (WINDOWS)
+# add_subdirectory(${SERVER_PREFIX}tools)
+# endif (WINDOWS)
+#endif (SERVER)
if (LL_TESTS)
# Define after the custom viewer and server targets are created so