summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2025-03-05 13:21:53 +0800
committerErik Kundiman <erik@megapahit.org>2025-03-05 13:21:53 +0800
commitbf949ce004c25917aabddd1cd24be812713e4602 (patch)
tree7347cc504b71a346d100b0307e2abfca2e3bf6dd /indra/CMakeLists.txt
parent53197ea0f31270a3094a6720b862bcaeee4851f2 (diff)
parent42ceac9695f7e098f15264977396a939c8ddfd23 (diff)
Merge remote-tracking branch 'secondlife/release/2024.12-ForeverFPS' into 2024.12-ForeverFPS2024.12-ForeverFPS
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 25570470db..5bf08f63aa 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -33,6 +33,11 @@ else()
set( USE_AUTOBUILD_3P ON )
endif()
+if (NOT DEFINED CMAKE_CXX_STANDARD)
+ set(CMAKE_CXX_STANDARD 20)
+endif()
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
include(Variables)
include(BuildVersion)