summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2013-01-05 09:17:51 -0500
committerNat Goodspeed <nat@lindenlab.com>2013-01-05 09:17:51 -0500
commit840cb864a3b41ccff310077eff487c3fa1d6b805 (patch)
treeabed8e38943228061790779c9b7568b9a4f49f83 /indra/CMakeLists.txt
parentab23506eb1d6a8435177a8e0b10331a5f03cff15 (diff)
MAINT-2155: replace embedded mac-updater.app with a Python script.
Remove mac-updater subtree from viewer source, along with the update_install bash script that invoked it. Remove all mention of mac-updater in CMakeLists.txt files and in viewer_manifest.py. Change Mac update_install bash script references in viewer_manifest.py and in llupdaterservice.cpp (which invokes it) to new Python update_install.py. Add update_install.py, messageframe.py (which puts up some Tkinter UI) and janitor.py (cloned from vita, it's exactly what we need here).
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 24c98bfada..45608de674 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -86,8 +86,7 @@ if (VIEWER)
add_dependencies(viewer linux-crash-logger-strip-target linux-updater)
elseif (DARWIN)
add_subdirectory(${VIEWER_PREFIX}mac_crash_logger)
- add_subdirectory(${VIEWER_PREFIX}mac_updater)
- add_dependencies(viewer mac-updater mac-crash-logger)
+ add_dependencies(viewer mac-crash-logger)
elseif (WINDOWS)
add_subdirectory(${VIEWER_PREFIX}win_crash_logger)
# cmake EXISTS requires an absolute path, see indra/cmake/Variables.cmake