summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2015-07-10 12:24:21 -0400
committerOz Linden <oz@lindenlab.com>2015-07-10 12:24:21 -0400
commit79ae34c1312a80fd9fab1c487a4556ba7254019c (patch)
tree53d01462b49ef0f1162e307340d54ee5c1c1a7da /indra/CMakeLists.txt
parenta6e5553e7429d32f0e1a145db8a680d99ee5013d (diff)
move doxygen generation to a subdirectory
Diffstat (limited to 'indra/CMakeLists.txt')
-rwxr-xr-xindra/CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 15b2329fc9..1e1d6dc585 100755
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -91,21 +91,11 @@ endif (LINUX)
add_subdirectory(${VIEWER_PREFIX}newview)
add_dependencies(viewer secondlife-bin)
+add_subdirectory(${VIEWER_PREFIX}doxygen EXCLUDE_FROM_ALL)
+
if (LL_TESTS)
# Define after the custom targets are created so
# individual apps can add themselves as dependencies
add_subdirectory(${INTEGRATION_TESTS_PREFIX}integration_tests)
endif (LL_TESTS)
-# add a target to generate API documentation with Doxygen
-find_package(Doxygen)
-if(DOXYGEN_FOUND)
- find_program(PERL perl) # I am not sure if this is really needed or not
- GET_FILENAME_COMPONENT(DOXYGEN_TOP_SRC_DIR ${CMAKE_CURRENT_SOURCE_DIR} PATH)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
- add_custom_target(doc
- ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
- COMMENT "Generating API documentation with Doxygen" VERBATIM
- )
-endif(DOXYGEN_FOUND)